Canalplan Bug Tracker



Anonymous Login
2019-06-19 18:43 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000468Canalplan [All Projects] Databasepublic2019-05-28 12:15
ReporterPeterScott 
Assigned ToNick Atty 
PrioritylowSeverityminorReproducibilityalways
StatusresolvedResolutionnot fixable 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000468: links from thumbnail to normal or large images go to wrong images
Descriptionhttps://canalplan.eu/place/qht4
first image "Concrete-hulled barge beached on canal between Sharpness dock and Purton"
https://canalplan.eu/photos/thumbnails/8/8o_o51.jpg
is correct thumbnail matching the description but links to (variously)
https://canalplan.eu/photos/normal/8/8o_o51.jpg
https://canalplan.eu/photos/big/8/8o_o51.jpg
which is the same image as
https://canalplan.eu/photos/big/8/8i_d5l.jpg
"Felt dwarfed in the canoe !"
which is itself correctly linked from here
https://canalplan.eu/place/rnk1
Steps To ReproduceAlso similar link issues from user's page
https://canalplan.eu/cgi-bin/showstuff.cgi?mode=user&id=403
TagsNo tags attached.
Attach Tags (Separate by ",")
Attached Files

-Relationships
+Relationships

-Notes

~0001816

Shultzy (updater)

Try using "https://canalplan.org.uk" as I don't get the same issue.

~0001817

Nick Atty (administrator)

.eu and .org.uk map to exactly the same code, it can't be that.

There's definitely something odd going on - there's a picture of the Edward Elgar displayed but with the caption that matches the concrete boat.

Sometimes the auto-thumbnail doesn't quite work, and sometimes there are caching issues, but I don't think this is either - I'll investigate.

~0001818

Nick Atty (administrator)

The two images are identical - to the byte - but the thumbnails are different, which is worrying as it suggests they once weren't.

I'll do some more checking over the weekend. Steve - if you come across this can you have a look at backups for /photos/big/8/8o_o51.jpg and /photos/big/8/8i_d5l.jpg any time from October 2011 onwards and see if they are different (and if either isn't the Edward Elgar).

~0001845

Nick Atty (administrator)

It looks like something went wrong, but I can't find anything else like that. Can you have a look in any backups to see if we have the older photograph anywhere?

~0001846

Stephen Atty (administrator)

Last edited: 2018-07-17 22:02

View 2 revisions

checked the last back up

steve@Debussy:/webstuff2/canalplan$ ls -ltr photos/big/8/8o_o51.jpg
-rw-rw-r-- 1 www-data www-data 119586 Sep 12 2015 photos/big/8/8o_o51.jpg
steve@Debussy:/webstuff2/canalplan$ ls -ltr photos/big/8/8i_d5l.jpg
-rw-rw-r-- 1 www-data www-data 119586 Sep 12 2015 photos/big/8/8i_d5l.jpg


both the same file

running stat on the files

  File: ‘photos/big/8/8o_o51.jpg’
  Size: 119586 Blocks: 240 IO Block: 4096 regular file
Device: 811h/2065d Inode: 24383058 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 20:47:15.654035587 +0100
Modify: 2015-09-12 18:17:23.282784068 +0100
Change: 2016-06-13 18:19:29.853961136 +0100
 Birth: -

steve@Debussy:/webstuff2/canalplan$ stat photos/big/8/8i_d5l.jpg
  File: ‘photos/big/8/8i_d5l.jpg’
  Size: 119586 Blocks: 240 IO Block: 4096 regular file
Device: 811h/2065d Inode: 24382948 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 20:47:06.449935327 +0100
Modify: 2015-09-12 18:17:21.218784132 +0100
Change: 2016-06-13 18:19:29.845961038 +0100
 Birth: -

so the files have been like this since 18:17 on 12/9/2015

Checking all the files

steve@Debussy:/webstuff2/canalplan/photos$ find . -name '8i_d*.*' -exec stat {} \;
  File: ‘./normal/8/8i_d5l.jpg’
  Size: 19257 Blocks: 40 IO Block: 4096 regular file
Device: 811h/2065d Inode: 25169748 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 09:59:09.989331557 +0100
Modify: 2015-09-12 18:27:26.806765366 +0100
Change: 2016-06-13 18:19:31.281978682 +0100
 Birth: -
  File: ‘./big/8/8i_d5l.jpg’
  Size: 119586 Blocks: 240 IO Block: 4096 regular file
Device: 811h/2065d Inode: 24382948 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 20:47:06.449935327 +0100
Modify: 2015-09-12 18:17:21.218784132 +0100
Change: 2016-06-13 18:19:29.845961038 +0100
 Birth: -
  File: ‘./thumbnails/8/8i_d5l.jpg’
  Size: 2607 Blocks: 8 IO Block: 4096 regular file
Device: 811h/2065d Inode: 25045198 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 09:59:03.105258832 +0100
Modify: 2015-09-12 18:23:13.090773228 +0100
Change: 2016-06-13 18:19:36.890047585 +0100
 Birth: -


steve@Debussy:/webstuff2/canalplan/photos$ find . -name '8o_o*.*' -exec stat {} \;
  File: ‘./normal/8/8o_o51.jpg’
  Size: 19257 Blocks: 40 IO Block: 4096 regular file
Device: 811h/2065d Inode: 25169873 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-18 17:02:15.260398379 +0100
Modify: 2015-09-12 18:27:28.386765317 +0100
Change: 2016-06-13 18:19:31.285978731 +0100
 Birth: -
  File: ‘./big/8/8o_o51.jpg’
  Size: 119586 Blocks: 240 IO Block: 4096 regular file
Device: 811h/2065d Inode: 24383058 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-16 20:47:15.654035587 +0100
Modify: 2015-09-12 18:17:23.282784068 +0100
Change: 2016-06-13 18:19:29.853961136 +0100
 Birth: -
  File: ‘./thumbnails/8/8o_o51.jpg’
  Size: 2525 Blocks: 8 IO Block: 4096 regular file
Device: 811h/2065d Inode: 25045317 Links: 1
Access: (0664/-rw-rw-r--) Uid: ( 33/www-data) Gid: ( 33/www-data)
Access: 2015-09-18 17:02:09.652336701 +0100
Modify: 2015-09-12 18:23:14.174773195 +0100
Change: 2016-06-13 18:19:36.894047635 +0100
 Birth: -

So only the thumbnail is different

2015 was when the structures were copied over onto the SSD

~0001847

Nick Atty (administrator)

The thing is, the thumbnail is "right" for the description. So it does look as though, unfortunately, we've lost that photo.

I've done a run across "big" and looked for files with the same MD5 hash, then looked at them. With the exception of this one, every pair (or triple) I've checked so far (I've not done all) is where someone has deliberately put the same photo at two places (eg, one of the photos at Cheddleton Lock and at
C Bridge). So I don't think we have a systematic destroyer of photos lurking somewhere in the code base, just a one-off breakage and damage.

I think we'll have to remove the faulty one completely, unfortunately.

~0002387

Stephen Atty (administrator)

Hopefully the photo changes that nick made the other day will have resolved the problem with lost photos.

~0002504

Nick Atty (administrator)

This looks to have been a one-off error from a long time back. Unable to fix and no sign of it repeating.
+Notes

-Issue History
Date Modified Username Field Change
2018-06-15 11:59 PeterScott New Issue
2018-06-15 12:42 Shultzy Note Added: 0001816
2018-06-15 13:06 Stephen Atty Assigned To => Nick Atty
2018-06-15 13:06 Stephen Atty Status new => assigned
2018-06-15 20:33 Nick Atty Note Added: 0001817
2018-06-15 20:54 Nick Atty Note Added: 0001818
2018-07-17 07:44 Nick Atty Assigned To Nick Atty =>
2018-07-17 07:44 Nick Atty Note Added: 0001845
2018-07-17 21:09 Nick Atty Assigned To => user17280
2018-07-17 21:54 Stephen Atty Note Added: 0001846
2018-07-17 22:02 Stephen Atty Note Edited: 0001846 View Revisions
2018-07-18 08:05 Nick Atty Note Added: 0001847
2019-04-21 20:10 Stephen Atty Note Added: 0002387
2019-04-21 20:11 Stephen Atty Assigned To user17280 => Nick Atty
2019-05-28 12:15 Nick Atty Status assigned => resolved
2019-05-28 12:15 Nick Atty Resolution open => not fixable
2019-05-28 12:15 Nick Atty Note Added: 0002504
+Issue History