Canalplan Bug Tracker



Anonymous Login
2019-05-21 17:49 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000576Canalplan [All Projects] Bugpublic2019-05-07 08:27
ReporterRichard Batram 
Assigned ToNick Atty 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
PlatformFirefox 66.0.2/Chrome 73.0.3683OSWindows 10 Pro For WorkstationsOS Version1803 (17134.648)
Product VersionProduct Build9.32.10 / 10:40 Jan 13 2019 
Target VersionFixed in Version 
Summary0000576: Built in account sign on not working
DescriptionAttempt to sign on with built-in account does not work. It accepts username and password but still displays the 'Log In/Create account' option. If I enter the correct username with an invalid password it correctly displays the incorrect username/password popup. I last used my built-in account in July 2018. I have cleared cookies and data from the web browsers but to no avail.
TagsNo tags attached.
Attach Tags (Separate by ",")
Attached Files

-Relationships
related to 0000577assignedNick Atty Changes in stored data 
+Relationships

-Upload File
Select File
Maximum size: 5,000 KB
+Upload File

-Notes

~0002269

Stephen Atty (administrator)

As a note - I cannot reproduce this with either of my built in accounts.

~0002270

Nick Atty (administrator)

Can you try a couple of things for me...

Firstly, does it do this if you try to log on from every page (try, say, the home page and a place gazetteer page)?
Secondly, does anything happen if you wait 30 seconds or so after you've given it your account and password?
And thirdly, do you get any errors in your browser (you can display a console in many browsers by pressing f12)? What browser are you using by the way?

~0002272

Richard Batram (reporter)

HI Nick

Tried to log on from several different screens but still does not work. Also, there is no change having waited 30 seconds after siging on.

There are no errors reported in the browsers console window and I've tried this on Firefox, Chrome and IE although I usually use Firefox.

~0002278

Stephen Atty (administrator)

Can you provide the user account you are using - you can do that by putting it in here but marking the note as private

~0002280

Nick Atty (administrator)

On my development system I've changed the password to mine (there is no way to read anyone's password but I can replace the encrypted version with another) and log on works perfectly. So that's not help.

Will keep thinking about this. If nothing is happening it sounds like nothing is coming back from the server.

~0002296

Nick Atty (administrator)

Unless you are blocking cookies from CanalPlan I have no idea what is going on here. And that doesn't sound likely with multiple browsers. You don't have anything unusual configured (an over-zealous ad-blocker for example) do you?

~0002299

Richard Batram (reporter)

I have nothing unusual configured in any of the browsers. I have also tried switching off everything to do with web security (Norton etc) but to no avail.

One thing I have noticed is that listing the current users from the home page it always shows 'Richard Batram' as being logged in?

~0002300

Richard Batram (reporter)

I meant that it shows me logged in on the server but not ob the client.

~0002321

Nick Atty (administrator)

I've deleted your logon record. Can you try again?

~0002322

Richard Batram (reporter)

Still no joy!
I can sign-on using my google account and the client treats me as logged on but not the built-in account.

~0002323

Stephen Atty (administrator)

Last edited: 2019-04-16 18:15

View 2 revisions

But google Sign On shouldn't be working any more

I think that the auth code was glitching if there was a new account matching the google one but they were still using the google sign on. I've changed the logic so that it shouldn't allow a bounce through if you've already migrated away from google

~0002326

Richard Batram (reporter)

I have just noticed that something very odd is happening. If I click the link in the bug tracker email it takes me to the site but the version is showing as 9.32.10 built on Jan 13th. I am able to sign on with my built-in account and I can see my preferences and saved routes. The sign-on popup looks slightly different also.

If I access the site as normal or log out I get version 9.32.13.6 built on Apr 16th. I can then no longer sign on?

I have cleared cookies and browsing data but the result is the same.

~0002334

Stephen Atty (administrator)

But the only difference between the two is the version tags on the logo and on the javascript files.

~0002335

Stephen Atty (administrator)

I've now updated the sub area scripts to match the main page

~0002336

Richard Batram (reporter)

Although the versions now look the same the signon popup still looks slightly different, ie. the three 'sigon with options' at the top are not colorised. I can still signon as before although I forgot to say last time that the site initially goes to a page with just 'Access Denied' , 'Login' and 'Proceed' displayed. If I click login or proceed the site is displayed showing me logged on.

~0002348

Stephen Atty (administrator)

The background issue is something odd which I've not looked into yet but the login code is the same.

The Bugtracker uses its own cookie as its a third party product so unless you cleared all the canalplan cookies including the one starting MANTIS then it's possible that you can come to the bugtracker and it will think you are logged in.

~0002350

Stephen Atty (administrator)

OK so I went into the database and basically used the salts and the hashes to set your password to something I knew and I managed to logon using richard@batram.com as you can see from the attached screen shot.

~0002358

Richard Batram (reporter)

Yes there is something odd! I can get to that point displayed in your image and stay logged on only if accessed via the bugtracker email link. If I hit the Home Page link and log off I am unable to log back in again.

~0002359

Stephen Atty (administrator)

All I did was reset your password and then go to the home page and login using your email address based user id.

~0002420

Stephen Atty (administrator)

Any update on this?

~0002421

Richard Batram (reporter)

It is still the same for me. I can sign on via the bug tracker link and access the whole site which treats me as if I was logged on.

From the home page it accepts my username and password but does not show me as logged on?

~0002424

Stephen Atty (administrator)

The thing that doesn't make sense is that there isn't any difference in the code.

~0002425

Shultzy (updater)

May I suggest that Richard Batram creates a new id and tests that out to see what happens.

~0002427

Richard Batram (reporter)

I have created an account with a username of martab. With this one I am able to logon as normal from both the bug tracker link and from the home page.

I also tried to create an account with a username of richard@batram.co.uk. This one works in the same way as my original account with a username of richard@batram.com and wont let me logon from the home page.

Could this be something to do with the contents of the username being parsed differently from the two different access points I have tried?
+Notes

-Add Note
Note
View Status
Upload File
Maximum size: 5,000 KB
+Add Note

-Issue History
Date Modified Username Field Change
2019-03-31 19:03 Richard Batram New Issue
2019-03-31 19:40 Stephen Atty Assigned To => Nick Atty
2019-03-31 19:40 Stephen Atty Status new => assigned
2019-03-31 19:44 Stephen Atty Note Added: 0002269
2019-03-31 22:09 Nick Atty Note Added: 0002270
2019-04-01 07:43 Richard Batram Note Added: 0002272
2019-04-02 15:38 Stephen Atty Relationship added related to 0000577
2019-04-06 11:31 Stephen Atty Note Added: 0002278
2019-04-06 12:04 Nick Atty Note Added: 0002280
2019-04-13 09:28 Nick Atty Note Added: 0002296
2019-04-13 09:48 Richard Batram Note Added: 0002299
2019-04-13 09:51 Richard Batram Note Added: 0002300
2019-04-16 14:15 Nick Atty Note Added: 0002321
2019-04-16 14:53 Richard Batram Note Added: 0002322
2019-04-16 18:07 Stephen Atty Note Added: 0002323
2019-04-16 18:15 Stephen Atty Note Edited: 0002323 View Revisions
2019-04-17 09:11 Richard Batram Note Added: 0002326
2019-04-17 20:21 Stephen Atty Note Added: 0002334
2019-04-17 20:28 Stephen Atty Note Added: 0002335
2019-04-18 07:59 Richard Batram Note Added: 0002336
2019-04-18 18:22 Stephen Atty Note Added: 0002348
2019-04-18 18:38 Stephen Atty File Added: Screenshot_2019-04-18_18-37-49.png
2019-04-18 18:38 Stephen Atty Note Added: 0002350
2019-04-19 09:02 Richard Batram Note Added: 0002358
2019-04-19 09:10 Stephen Atty Note Added: 0002359
2019-04-19 09:20 Stephen Atty File Added: Screenshot_2019-04-19_09-17-48.png
2019-05-06 09:35 Stephen Atty Note Added: 0002420
2019-05-06 09:45 Richard Batram Note Added: 0002421
2019-05-06 15:29 Stephen Atty Note Added: 0002424
2019-05-06 19:01 Shultzy Note Added: 0002425
2019-05-07 08:27 Richard Batram Note Added: 0002427
+Issue History